Flipper 0.26.0

Hello beautiful feature flagger! Hope you are having a fine day. Let's get into this last release, shall we? We shall. UI BUG FIX First, big thanks @Lockyy for fixing a bug in flipper-ui. Previously, if confirm_fully_enable was on but feature_removal_enabled was off, it would show…

Flipper 0.25.1 to 0.25.4

Welp, I missed a few releases. Sorry about that. But I'm sure you forgive me. :) 0.25.1 * ActiveRecord: use provided gate_class option when calling #get_all * Relaxed the rack-protection version to support latest. * Configure ActiveRecord adapter immediately upon require of flipper-active_record 0.25.2 * Fix deprecation warnings…

Flipper 0.25.0

Hello from Nevada and Great Basin National Park! I'm vacationing (12 national parks) so this release email is a little tardy. But better late than never, right? Breaking Changes * Removed previously deprecated options and settings. Those upgrading from <0.21 should upgrade to ~>0.24 first and fix any deprecation warnings when initializing Flipper. Additions/

Flipper 0.24.1

New day. New flipper. Get it while its 🔥. Additions * ☎️ flipper-api: exclude_gates parameter to exclude gate data in GETs. Probably very rare use case, but if you just want on/off from the API you can slim down responses now. * 🚫 Make it possible to disable internal memoization. Sometimes you really…

Flipper 0.24.0

Another tiny release for you today. Removals * Removed support for Ruby 2.5 (which was end of line 9 months ago) * Removed support for redis-rb < 3 (and fixed deprecated use of Redis#pipelined) (https://github.com/jnunemaker/flipper/pull/603). Additions * Add Ruby 3.0 and 3.1 to the…

Flipper 0.23.1

Just a tiny release for ya today. * @mlarraz opened a PR for releasing the dalli constraint so Flipper now supports Dalli 3.x. * @bkeepers tracked down a bug that was causing changes to Flipper's config in initializers to not work. This did not affect config/application.rb stuff, but did…

Flipper 0.23.0

Oh, hey! You subscribed to OSS updates for Flipper so here you go. Flipper 0.23.0 is hot off the press with Rails 7 support (mostly done here). Along with Rails 7, there were several minor additions/changes that could be interesting but won't slow you down. * We now…